Land F/X Cloud Licensing is Having Trouble Connecting
Issue
You saw the following error message:
Land F/X Cloud Licensing is having trouble connecting.
Cause
This error can result from an issue with your Internet connection or with our Cloud service.
Solution
1. Test your Internet connection by going to landfx.com.
If landfx.com is not loading on your computer, you are likely experiencing an Internet outage. If so, contact your Internet service provider to troubleshoot your Internet connection.
Is landfx.com loading? If so, your Internet connection is working. Move on to the next step.
2. Check our Cloud Data Outage Status & Information page.
If a cloud outage is reported, your issue is the result of that outage. You can check for the outage status by continuing to refresh the Cloud Data Outage Status page linked above.
If our Cloud Data Outage Status page is reporting no outage, send us a technical support ticket describing your issue so our team can troubleshoot.