Nuke Tool Errors
Issue
You tried to use our Nuke tool to "clean" a drawing, but you received an error message and the Nuke tool isn't working (or is "erroring out").
The Nuke tool was designed to clean files you receive from others. Do not use the Nuke tool on your own drawing files.
Causes
If the Nuke tool isn't working properly, you can usually attribute it to one of three possible causes:
- Your Proxy Object settings are not configured correctly.
- The drawing consists of only one object – a block – which needs to be exploded before Nuke can work.
- The drawing is completely empty, or all objects in the drawing are either proxy objects or annotative (and thus the drawing can't be saved).
If the Nuke tool caused an error in a drawing that includes geographic location (geolocation), you'll need to remove the geolocation before you can Nuke a drawing. Here's how.
Solution
Your first step should be to change the Demand load ObjectARX setting to Command invoke in the CAD Options dialog box.
Close the file you're trying to Nuke. Then type Op in the Command line and press Enter to open the Options dialog box.
In the Options dialog box, select the Open and Save tab. Pictured below are our recommended settings for the ObjectARX Applications.
Particularly important for the ability to Nuke correctly is the Demand load ObjectARX setting, which you should change to Command invoke.
Once you've changed this setting, open the drawing you were trying to Nuke. You should now be able to Nuke successfully, unless:
-
The drawing consists entirely of one block.
If so, explode the block and attempt to Nuke again. This time, it should work.
-
The drawing is either completely empty or consists entirely of proxy or annotative objects.
If so, the Nuke tool won't be able to function at all, since it needs to save the drawing.
Not sure what to do next? Your drawings still need to be cleaned. At this point, you'll want to follow the steps outlined in our Cleaning Drawings Manually article.