Security Certificate Error (Opening AutoCAD or F/X CAD)
Issue
When starting AutoCAD or F/X CAD you received the following error message:
Security Alert: Revocation information for the security certificate for this site is not available. Do you want to proceed?
Cause
In general, this message appears when you open a website with a security certificate that has either been revoked or flagged as revoked. However, you can assume that Land F/X and Autodesk both keep their security certificates updated. You can also receive this message for a number of other reasons, including an inaccurate time or date setting on your computer.
So why are you receiving this type of message when simply opening CAD? It's because our software uses Internet Explorer to access the Land F/X database, where all our plants, irrigation equipment, and other components are stored.
Solution
Step 1
If you receive this error, first try navigating to the Purchase page on our website using Internet Explorer. Copy and paste the following URL into the search box in Internet Explorer: https://www.landfx.com/purchase.php?renewals=0
Once you're there, check whether a Certificate message pops up and give you the option to Allow or Trust the certificate. If so, select this option, and you should be able to open CAD without incident.
If not, the problem may lie deeper. Read on for the solution.
Step 2
First, click View Certificate on the Security Alert message to open the certificate and examine it.
Has the Certificate Expired?
The certificate will look something like the image shown below. Open the General tab, and check the information next to Issued To and Valid From.
The certificate will be Issued to either landfx.com or autodesk.com.
The dates following Valid from will tell you whether the certificate is still valid. If the "to" date has already passed, please alert us (if the certificate was Issued to landfx.com) or Autodesk (if the certificate was Issued to autodesk.com). However, as mentioned above, Land F/X and Autodesk are extremely vigiliant about keeping these certificates up to date, so it's highly unlikely that the certificate is expired.
Who Issued the Certificate? Is It Still Valid?
If the certificate has indeed not expired, you'll need to contact the issuer of the certificate to verify that it is in fact valid.
You can find the issuer of the certificate next to the words Issued by.
Are All Necessary Windows Updates Installed?
Next, check to ensure that you've installed all available Windows updates that handle certificates. Of specific importance is the Update for Root Certificates. Make sure this option is turned on in your Group Policy settings. (The path to your Group Policy settings will vary depending on your version of Windows.)
Correct Your Time/Date Settings and Clear the Secure Sockets Layer (SSL) State
Correct your computer's date and time settings. Then open Internet Explorer and clear your SSL State in your Internet Options. To do so:
Open Internet Explorer. Click the gear icon in the top right corner of your screen, and select Internet Options from the menu that opens.
In your Internet Options, select the Content tab. Then click the button to Clear SSL state.
Reregister DLL Files
Your next step should be to reregister these DLL files:
- regsvr32 softpub.dll
- regsvr32 wintrust.dll
- regsvr32 initpki.dll
- regsvr32 dssenh.dll
- regsvr32 rsaenh.dll
- regsvr32 gpkcsp.dll
- regsvr32 sccbase.dll
- regsvr32 slbcsp.dll
- regsvr32 cryptdlg.dll
You can also reregister the .dll files automatically using the Windows solution linked here.
This solution sources information from the Bright Hub article Dealing With Revoked Security Certificates.