Fatal Error or Fatal Exit
Issue
You received a Fatal Error or Fatal Exit message while working in AutoCAD or F/X CAD, or when attempting to open CAD. Here are a few examples of a Fatal Error or Fatal Exit message you might have received:
- Fatal error: No database connection (when trying to use a Land F/X tool)
- Fatal exit: No database connection in the Command line
- Fatal error: Unhandled access violation reading 0x0010 Exception ... (Working in a drawing that includes custom linetypes or working in AutoCAD 2016)
- Fatal Error: Unhandled Access Violation Reading 0x70d94980 Exception at fb8a7664h (with AutoCAD 2017 or AutoCAD Civil 3D 2017)
- Fatal error: Unhandled exception or Unhandled exception e0434352h exception at fda3a06dh (or similar)
- Fatal error: Unhandled delayload " AdSpatialReference.dll" Module Not Found"
- Fatal error 0x0000 (when starting AutoCAD or F/X CAD)
- Fatal error (when saving to a shortcut)
- Fatal error: Unhandled delayload
- Fatal Error: Unhandled e0434352h Exception at XXXXXXXX
Seeing a Fatal Error after just installing AutoCAD 2017 or AutoCAD Civil 3D 2017? You can resolve it quickly by installing the latest Service Pack for AutoCAD 2017. Instructions >
Causes & Solutions
Your solution will depend on either:
- The specific Fatal error or Fatal exit message you're seeing, or
- What you are trying to do in CAD when you see the error
• Fatal Exit: No database connection
A No database connection error is letting you know that you are unable to access your Land F/X database. These errors generally apply only to installations that are using Local Data.
Your database connection can drop for any of the following reasons:
Reason 1: CAD needs to be restarted.
You can often resolve this error quickly by restarting CAD.
If restarting CAD doesn't resolve the issue, move on to the other possible causes of this error.
Reason 2: You actually have Cloud data, and the configuration is mistakenly thinking that you have Local Data.
If your office has Cloud Data and you're getting a No database connection error, you're either experiencing a problem with your database configuration or a bug in the software.
- Are you getting this error attempting to do anything at all? If so, that's a sign of a configuration issue.
In this case, type ENTERPRISE in the Command line and press Enter.
In the dialog box that opens, confirm that Use cloud data is checked.
If not, check this option and click OK.
This is also a good opportunity to confirm with your IT admin or CAD manager that your office is properly configured on Cloud Data.
- Are you only getting the No database connection error when attempting some actions with the software, but you're able to do others just fine?
If so, you've likely encountered a bug in the software. Specifically, our developers missed a database call and did not upgrade it to be compatible with Cloud Data. If so, just let us know your exact steps to reproduce the error, and we’ll get it fixed! (See A bug in the software code below for instructions.) The good news: Because other parts of Land F/X are working, you should be able to do something else in your plan while we work on repairing the bug.
Reason 3: A bug in the software code.
In this case, the programmer did not foresee the steps that you took (perhaps many operations in a row), and the database connection was closed prematurely. If you can replicate the exact steps that generated this error (and the error tends to occur after you've at least one thing), it's likely the result of a bug.
The easiest way to check for a bug is to check our list of recent updates.
- Don't see a recent update that's related to what you tried to do when you saw the error? You've likely ruled out a bug. Move on to the next possible cause/solution.
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Do you see a recent update that's related to what you tried to do when you saw the error? If so, there's a good chance you've detected a bug in the code. For example, if you saw a bad argument type error when you attempted to place a Reference Note Callout, and a recent update has to do with Reference Note Callouts, there's your bug! If you think you've found a bug, please let us know by sending us a technical support ticket. Make sure to include the following items in the ticket:
- The exact text of the error message, and a screenshot of the error message (if you have it)
- A description of the action you took that generated the error message (such as placing a plant, editing a detail, etc.)
Not a bug? You are likely experiencing ...
Reason 4: A problem with your actual database.
If you get this error in attempting to do anything, even from a blank drawing, you can bet that it's resulting from one of two possible causes:
- You actually have Cloud data, and the configuration is mistakenly thinking that you have Local Data. Here's what to do >
- You have Local Data, and the connection to your database is dropping. If so, ask your IT admin to troubleshoot your Land F/X installation.
If the Fatal Error: No database connection or Fatal Exit: No database connection error is actually the second or third error message you received in a row, please note that we will want to see the first error message you saw.
However, the problem could also be that your server is running out of disk space, or just needs to be rebooted. Have your IT administrator verify that your server has sufficient disk space, and then reboot the server. Try the action that generated the error again. No error? You've resolved the issue.
If your server wasn't the issue, or if you're still getting the error, we'll need to investigate. Please send us a technical support ticket that includes:
- A screenshot of the first error message you received before seeing the Fatal Error or Fatal Exit
- The text of that error message
- A note that you also received either a Fatal Error: No database connection or Fatal Exit: No database connection message
- A brief description of the action you took that generated the error
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If you saw this exact error message while:
- Working in a drawing that contains custom linetypes: Read on for the cause and solution.
- Using AutoCAD 2016, but not while working in a drawing that includes a custom linetype: Scroll down and follow the steps for All other Fatal Error or Fatal Exit messages at the bottom of this page.
You're here because you received a Fatal Error message when working in a drawing that includes a custom linetype.
The message may include the text Fatal Error: Unhandled access violation reading 0x0010 Exception ..., as pictured to the right.
You may have seen this error when:
- Changing the linetype from the Properties panel (as shown to the left), or
- Simply working within a drawing that includes custom linetypes.
Cause
This error occurs in drawings where a TrueType font (TTF) is being used within a custom linetype, along with a few other conditions described below.
Custom standard linetypes are available and can be loaded into your linetype options. These linetypes pull their text style from the Standard text style in the AutoCAD Text Style Manager.
If this text style is set to an SHX font style (example: avantg-f.shx), you should be able to change the linetype of a selected line without generating the error.
However, if you're using a TTF text style, you'll see the Fatal Error message.
This error is the result of an AutoCAD bug and is not isolated to Land F/X users.
Are you using our Custom Line tool?
Note that Custom Line pulls from our Callout Text style.
The same caveat applies to this tool: If you're using SHX fonts, you should be safe. If you're using TTF, you'll see this error when changing linetypes.
Solution
We've developed a tool that will resolve this issue.
The LineTypePatch tool will work with the following versions of F/X CAD:
- 2020: English, French, and Spanish
- 2016 – 2019: English
Have AutoCAD, or a different version of F/X CAD? Here's what to do.
Download and run (double-click) the LineTypePatch tool, linked below.
Leave the Debug Patch option unchecked, and click Next.
Restart F/X CAD. If you can work without F/X CAD crashing, you've resolved the issue.
Is F/X CAD still crashing after you applied the patch? Here's what to do:
Run the patch again. This time, check the Debug Patch option and click Next.
The Patch tool will patch your installation with an update that will create a log file for our team to review.
Once the debug patch has been applied, start F/X CAD and repeat the steps that made it crash. Locate the LineTypeDebug.log file on your desktop, and send it to our team in a technical support ticket for review.
After sending in the log file, run the patch again.
Leave the Debug Patch box unchecked, then click Next. This step will prevent you from continually creating these log files, which will balloon in size.
Have AutoCAD, or a version of F/X CAD that won't work with the patch?
If you have AutoCAD, or a version of F/X CAD that's incompatible with the LineTypePatch tool, or if the tool just didn't resolve the issue, you have a couple of options for resolving this error:
- Workaround 1: While not generally recommended, changing the text style to an SHX style (example: avantg-f.shx) will resolve the fatal crash.
- Workaround 2: Another workaround (though not always Fatal Error–proof) until Autodesk can fix this bug would be to change the linetype from the Layer Properties Manager rather than from the Properties panel.
Keep in mind that:
• This second workaround will affect all lines in the drawing that land on that specific layer (and of those lines, that are set to "by layer")
• If you happen to go to the Properties panel and click the Linetype option (despite that you're changing the linetype from Layer Properties Mnager), you'll still get the Fatal Error message.
• Sometimes just having the Properties panel docked and opening files with custom linetypes can cause the Fatal Error message as well.
It's also a good idea to send us a technical support ticket letting us know you're experiencing this error, so we can continue investigating.
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Cause
If CAD crashed when you tried to run the Publish or Batch Plot command, you might have a a damaged or improper page setup or plotter configuration.
Solution
Follow our troubleshooting steps to resolve this issue.
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If a Fatal error message pops up right when you launch CAD, here's what to do:
1. Right-click the AutoCAD or F/X CAD shortcut on your desktop.
Select the Properties option from the menu that opens.
2. Select the Shortcuts tab in the Properties dialog box.
Add the following text at the end of the Target field: /nohardware
3. Try launching CAD again.
Still getting a Fatal error message? Scroll down to the All other Fatal Error messages and scenarios steps at the bottom of this article.
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You can address this error by following our steps to run the RECOVER command on the DWG or series of DWGs you're trying to open.
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First, are you getting the following error message right after installing AutoCAD 2017 or AutoCAD Civil 3D?
Fatal Error: Unhandled Access Violation Reading ...
- Yes: Please see the solution to this specific Fatal Error message.
- No, I'm getting another Fatal Error, or I don't have AutoCAD or F/X CAD 2017: Move on to the steps listed below.
The following Fatal Error messages will require the same general set of troubleshooting steps:
- Fatal error: Unhandled exception or Unhandled exception e0434352h exception at fda3a06dh
- Fatal error: Unhandled delayload " AdSpatialReference.dll" Module Not Found"
- Fatal error 0x0000 (when starting AutoCAD or F/X CAD)
- Fatal error (when saving to a shortcut)
- Fatal error: Unhandled access violation reading 0x0010 Exception ... (working in AutoCAD 2016)
- Fatal error: Unhandled delayload
- Fatal Error: Unhandled e0434352h Exception at XXXXXXXX
Please complete the following troubleshooting steps in the order listed. After each step, restart your computer and reopen CAD. If you're not getting the error, you've resolved the issue. If you're still getting the error, move on to the next step.
1. Ensure that your Windows installation is up to date. If necessary, run the Windows update.
2. Once you're sure Windows is up to date, restart your computer. (No need to restart your computer again after this step. Just open CAD and see whether you're still getting the error.)
3. Install the latest Autodesk Service Pack or Update for your year version of AutoCAD.
F/X CAD users:
- F/X CAD 2018 & newer: The update is bundled into the F/X CAD installer. To get the latest updates, follow our steps to reinstall F/X CAD using the latest installer from our site for your year version.
- F/X CAD 2016 – 2017: The Service Pack for your year version is built into your installation.
4. Update your graphics card drivers.
5. Turn off hardware acceleration.
6. Clear the temporary files from your computer.
7. Turn off your anti-virus or anti-malware program. Then reinstall/repair AutoCAD or F/X CAD.
The reinstall option will not be available for .NET on some Windows 10 machines. If your issue relates to a possible Microsoft .NET Framework reinstall or update, please note that you may be experiencing an issue resulting from a conflict between Autodesk and Microsoft’s .NET Framework 4.7. This latest version of the .NET Framework (Windows 10 Creator’s Update) is an Autodesk and Windows known issue. More information >
9. Uninstall and reinstall Visual C++.
10. Tried all the other steps and you're still getting the error? The problem may lie in your Autodesk license validation. This issue may be occurring as a result of:
- An Internet outage at Autodesk.com. Go to that site. Is it down? You've found the problem.
- Your Internet Explorer requiring an update: Download Internet Explorer to update it.
- Malware Security software: Your IT administrator may need to investigate for either of these causes.
- Installing F/X CAD after previously having another version of AutoCAD (such as the academic version): In this case, follow our steps to check for and uninstall any previous versions of AutoCAD or F/X CAD (taking care not to uninstall the version you are currently using).
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