Unwind Skipped on Exception – Access Violation 0xC0000005
Issue
You received an error similar to the following:
Unwind skipped on exception – access violation 0xC0000005
In addition to the error message, you might see the following text in the AutoCAD Command line after you've attempted an action such as running a schedule on a Work Area:
error: Unknown exception occurred
; warning: unwind skipped on unknown exception
Causes
This error can result from:
- A bug in the way AutoCAD handles repeated information requests. If you leave AutoCAD running for several days without shutting down your computer, you'll inevitably receive this error.
- A corrupt drawing
- An issue with an object, such as a hatched area
- Another benign cause we have yet to pinpoint in updating our landfx.vlx
Solution
You can prevent this issue in future drawings by consistently taking care to:
- Shut down and restart your computer periodically – generally a best practice for optimal AutoCAD and general computer performance. We recommend shutting down when you leave work each day.
- Follow our steps to clean your drawings and all Xrefs – and making it a future habit to clean all drawings you receive from others.
Are you seeing the Unknown exception occurred text (listed above) in the AutoCAD Command line in addition to the error? Or are you seeing the error after attempting a specific action such as running a schedule on a Work Area? You may be experiencing an issue with an object in your drawing, such as a hatched area.
If so, you can address the issue by isolating the object causing the error. To do so, systematically delete certain objects and repeat the action that caused the error. For example, if you're trying to run a schedule on a Work Area, try deleting objects such as blocks or hatched areas from the Work Area (one object at a time) and running the schedule again each time. Once you can perform the action (e.g., running the schedule) without seeing the error, you've removed the object that's causing the error.
If a block or hatch is causing the error, you can simply re-place the block or re-draw the hatch. These steps have solved the issue in past cases.
1. Restart your computer, then reopen CAD.
Still seeing the error? If so, move on to the next step.
2. Try to re-create the error in a blank drawing without corruption. If you find that you're unable to re-create the error in a blank, clean drawing, follow our steps to clean the affected drawing and all Xrefs.
Still seeing the error? If so, move on to the next step.
3. Delete all files from the location C:\Users\username*\AppData\Local\Temp
*Where username is your computer username
If the issue continues, we've found this error to be benign when updating Land F/X. The cause is currently unknown and caused by something in the AutoCAD installation, but the Land F/X plugin update is unaffected and has so far completed without error. In this case, you can just ignore the error.
If you find these solutions didn't work and you have an issue caused by the error impeding your use of our plugin, feel free to let us know via a technical support ticket.