Missing AutoCAD SHX Font, Such As Italic Complex, Roman Complex, Roman Duplex, Roman Simplex, or Roman Simplex0
Issue
You're missing a CAD installed SHX font, such as one of the following:
- Italic Complex (italicc.shx)
- Roman Complex (romanc.shx)
- Roman Duplex (romand.shx)
- Roman Simplex (romans.shx)
- Roman Simplex0 (roman0.shx)
- CityBlueprint
- Swiss 721 Black
- Swiss 721 Black Extended
- Swiss 721 Bold
- Swiss 721 Bold Condensed
- Swiss 721 Bold Condensed Outline
- Swiss 721 Light
- Swiss 721 Roman
If so, you may be able to fix the issue by repairing and reinstalling CAD. If that doesn't work, see our instructions on fixing corrupt fonts.
Cause
The missing SHX font message is likely the result of your Support File Search Path not being set properly. In more extreme cases, there could be something wrong with your CAD installation, which might require you to repair your installation.
Solution
To address this error, open the Options dialog box:
Manage ribbon, Options button
type Options in the Command line
right-click in the Command line and select Options from the menu
Tools pull-down menu
Select the Files tab, then expand the Support File Search Path item by clicking the plus (+) sign next to it.
In the expanded Support File Search Path folder, the top entry should be: C:\Users\*username\AppData\Roaming\Autodesk\AutoCAD 20xx\RXX.X\enu\support
(where *username is your Windows username, 20xx is your version of AutoCAD, and RXX.X is the name of the single folder in your AutoCAD version folder)
If the top entry in the Support File Search Path is NOT the path shown above, you'll need to complete the following steps to correct the issue.
1. Ensure that your hidden files and folders are turned on.
2. Once you're sure that your Hidden and System files are turned on, click Add. Then click Browse.
3. The Browse for Folder dialog box will open.
Scroll down and expand the entry for This PC (if you have Windows 10) or Computer (if you have Windows 7).
Then expand the Local Disk (C:) entry.
4. Once you've expanded the Local Disk C: entry, expand the following entries:
- Users
- your username (example: Jason)
- AppData (Note: you won't see this folder unless you have your hidden files and folders enabled.)
- Roaming
- Autodesk
- AutoCAD 20xx (where 20xx is your version of AutoCAD or F/X CAD)
- Rxx.x (The exact name of this folder will vary depending on your version.)
- enu
Then highlight the folder Support and click OK.
This folder tree will be added to the Support File Search Path.
5. The Support File Search Path will now include the folder tree you added:
C:\Users\*username\roaming\autodesk\autocad 20xx\rxx.x\enu\support
Select this folder tree and click Move Up.
6. Continue to click Move Up until the folder tree is at the top of the list.
Then click OK to save the change.
7. Close and restart CAD. If you don't see an error message when attempting to place font, you've resolved the problem.