Download Our Updated Hatch Patterns Manually (June 2024)
Issue
You're experiencing any of the following hatch-related issues with any Land F/X tools (planting, Reference Notes, irrigation, etc.):
- Hatches looking fragmented or broken apart
- Hatches with scales that are too large or too dense
- Hatches that place blank or empty
- Hatches that are not appearing in schedules
- File size bloating
Cause
Our June 2023 hatch release included many complex custom hatches we created. Since then, we've analyzed performance data and listened to user feedback to understand how our hatches can improve. The new hatches are now available for download to correct any of the issues listed above. These downloadable patterns look clear at every size and shape, and do not increase file sizes.
Solution
Option 1: Trigger the download of all new hatch patterns.
We highly recommend this option in most cases, as it's the most effective and efficient method of correcting the hatch issues listed above. You might want to complete the steps in Option 2: Back up your custom hatches and delete the problematic hatches instead if:
- You're hesitant about deleting folders or losing custom hatch patterns.
- Your office is set up such that it might take an excessive amount of time for an internal discussion to happen on how this process should take place – for example, if you have a strict CAD manager or if you work at a larger organization where this process would require upper-management approval
1A. Make backups of any user hatch files in the LandFX\Hatch folder, and of any non-Land F/X PAT (.pat) files in the LandFX\Patterns folder.
1B. Delete all files from the LandFX\Patterns folder, and delete all XML and BAK files from the LandFX\Hatch folder.
After you've deleted these files, all new hatches will download automatically whenever you select them in the normal use of Land F/X tools
1C. If a problematic hatch is currently assigned to a Land F/X object, such as a plant or Reference Note, in any of your drawings, you'll need to assign a different hatch pattern to that object temporarily. You can then assign the original hatch to that object to trigger the new download.
Option 2: Back up your custom hatches and delete the problematic hatches.
As mentioned above, we recommend Option 1: Trigger the download of all new hatch patterns in most cases. Option 2 involves a more complex process that's in place for users who are hesitant to delete the folders as required in Option 1, or for organizations whose CAD policies or administrative protocols would render Option 1 impossible or overly complicated.
2A. Open our Hatch tool:
F/X Site ribbon, Hatch flyout
F/X Site menu, Hatch option
or type FX_SiteHatch in the Command line
2B. In the Hatch dialog box, make note of the name of each problem hatch.
Take note of the specific category (Detail, Drip, Groundcover, Site) from which you're selecting the problem hatch.
2C. Navigate to the folder LandFX\Hatch and make backups of any user hatch XML files (for example, user - detail.xml, user - groundcover.xml, user - site.xml etc.)
2D. Delete the XML and BAK files for the problematic hatch category and for the site category.
In this example, if a hatch in the groundcover category were causing the issue, you would need to delete the following files:
- _groundcover_ XML
- _site_ XML
- user - groundcover.bak BAK
- user - groundcover XML
- user -site XML
2E. Navigate to the folder LandFX\Patterns folder, search for the names of the problem hatches, and delete them individually.
2F. If a problematic hatch is currently assigned to a Land F/X object, such as a plant or Reference Note, in any of your drawings, you'll need to assign a different hatch pattern to that object temporarily. You can then assign the original hatch to that object to trigger the new download.