Cannot Connect to Server (Local Data)
Issue
You saw a Cannot connect to server message when using Land F/X with Local Data.
Cause
Your ODBC connection to the MySQL database is configured improperly.
The "server" mentioned in this error message is actually your F/X Server. If you have a Single-User installation, this component will be on your computer. If your office has a computer that functions as a central server, your F/X Server will likely be on that computer.
Want to learn more about ODBC, MySQL, and the F/X Server? See our Definitions article.
Solution
Examples of a Single-User installation include:
- A single office computer with our software installed that is not connected to a Land F/X server on a central office server
- An installation of our software on a home computer or laptop
If you have our software installed in one of these ways, here's what to do:
1. Troubleshoot your ODBC connection for a standalone installation.
2. If you see a Connection Failed message, follow our steps to test and configure your MySQL connection.
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Here's what to do if your office has our software installed on a central server:
1. Follow our steps to troubleshoot your ODBC connection for a server installation.
2. If you experience lag time while testing your ODBC connection, you likely have a network connection issue. Follow our steps to ping your server name.
3. If your server responds quickly to the ping BUT your ODBC cannot connect, follow our steps to test and configure the MySQL service on the server.
4. If the test takes more than a second to show Connection Successful, follow our steps for troubleshooting a slow connection.
5. Go back to your workstation and troubleshoot your ODBC connection again. Still having an issue connecting to your server? Contact your IT department for help.
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