MySQL Stops or Will Not Start
Issue
You're having trouble starting the MySQL database on your computer. It either:
- Has stopped unexpectedly, or
- Will not start after you've stopped it and are trying to start it
Getting an Error 1067 message? Use the Existing installations solution.
Cause
Corruption in a few key files can prevent the MySQL database from starting.
Solution
New Installations
If you're installing one of our plugins for the first time, or installing on a new computer, you can address this issue extremely quickly by removing a few key files from your computer and reinstalling.
1. Follow our instructions to uninstall Land F/X.
2. Delete the LandFX folder from your computer – unless you have custom content saved in it.
If you have custom content saved in your LandFX folder – such as blocks, hatches, details, or custom settings, do not delete this folder.
Instead, change its name to LandFXold.
If you're installing our software for the first time, odds are you don't have custom content saved in this folder – but we can never be too careful!
3. Reinstall Land F/X on your computer using our installation guide.
MySQL still not starting? Try the Existing installations solution.
Existing installations
The following steps will allow MySQL to start if:
- You received an Error 1067 message when trying to start MySQL, or
- MySQL simply won't start
1. Navigate to the folder C:/Program Files (x86) /MySQL/MySQL Server 5.5.
Open the file named my in a text application such as Notepad.
2. In the text file, look for an entry called datadir.
Note the folder path in this entry (example: C:/LandFX/data).
3. Check the datadir folder path against the actual location of the folder LandFX/data on your computer.
If you have a Single-User installation, this folder will usually be on your C: drive.
If your office uses our software on a central server, your LandFX folder will likely (or should) be mapped to a letter drive other than C:, such as L:, M:, X:, etc.
4. If the two paths don't match, correct the datadir entry to reflect the actual location of the LandFX/data folder.
For example, if you've moved your Land F/X installation to a new server, the datadir entry needs to reflect the letter drive of that server.
In our example, we've changed the datadir entry to reflect a LandFX folder that has been moved to a server on the L: drive.
5. Save and close the text file.
6. Once you're sure the datadir entry in the text file matches the path of the folder LandFX/data, navigate to the folder LandFX/data.
This folder will be on your C: drive if you have a Single-User installation.
If your office uses our plugins on an office server, you'll need to navigate to the drive letter of that server. Then open the folder LandFX/data.
Delete the following three files:
- ib_logfile0
- ib_logfile1
- (YOUR USERNAME).err (this file will have your username as its filename, but will definitely have the extension .err).
7. Press the Windows + R keys (Windows keyboard) or Command + R keys (Mac keyboard) to open the Run dialog box.
Type services.msc in the search box, and click OK.
8. In the Services dialog box, scroll down to and select the MySQL entry.
Click Start the Service to start MySQL.
If MySQL starts, you're in business! You should now be able to use our software successfully.
MySQL still not starting? Getting an error message? You are probably dealing with a permissions issue. Your next step should be to ensure that you (or any users you are helping) have Read-Write permissions to the LandFX folder on your network.