Unable to Establish an Internet Connection to the Registration Server to Validate Your Support ID (Installing or Activating a Land F/X Plugin)
Issue
You received the following error message when attempting to install or activate a Land F/X plugin – and you are positive that your Internet connection is working.
Unable to establish an Internet connection to the registration Server to validate your Support ID
Cause
Your TLS settings in Internet Explorer are likely disabled, preventing you from accessing our online database – or using our software at all.
Solution
Follow our steps to configure your TLS settings.
Your system should now be able to query Land F/X, allowing you to activate successfully.
Still getting the error after enabling your TLS settings? You may need to disable a firewall on your computer.