Missing File Error (Placing Rotary Heads) – Custom Rotary Family Arcs Are Missing
Issue
When trying to place a rotary head from a custom rotary family, you saw a Missing file error message. Example: Missing file: C:\LandFX\Blocks\Graphics\Irrigation\radius\r51\LAFX-ARC-R51-0-5-Q.
Seeing this error when using one of our other tools, and not when placing a rotary irrigation head?
If so, here's what to do.
Cause
We've made some updates to the arcs for custom rotary families to provide a more dynamic look for the proper arc folder to match the custom rotary family. We've seen a few issues with custom rotary families as a result.
Solution
1. Save any work and close CAD.
2. Navigate to the folder LandFX\Blocks\Graphics\Irrigation\radius. From within that folder, copy the subfolder r5 to a temporary location on your computer, such as your desktop.
3. Rename the copied r5 folder in the temporary location to match the name of your custom rotary family. For example, if your custom rotary family is r51, name the copied folder r51.
4. Open the renamed folder, and rename all files within it to match the name of your custom rotary family.
For example, if your custom rotary family is named r51, rename the files named LAFX-ARC-R5-01-H to LAFX-ARC-R51-01-H.
Don’t see all the files in the path that was specified in the Missing file error message? You may need to open a blank drawing, add equipment to your Land F/X project, and, when doing so, select one of the default Land F/X symbol families whose files you need to rename as shown above. The system will then download that family to your folder, and the equipment files within that family will be available for you to rename.
Quick video
Need to rename a large number of files? See our Customizing Rotary Symbols Power Tip, linked to the right, to find out how to rename files in mass during customization.
5. Once you've renamed all files within this folder, move the folder back to the location LandFX\Blocks\Graphics\Irrigation\radius.
Note for offices with multiple Land F/X installs:
If your office has local installs of Single-User Land F/X on multiple computers, you'll need to complete these steps on one Land F/X workstation in your office and then copy the newly created folder to each additional Land F/X workstation.
If your office has a Multi-User Land F/X installation using a shared LandFX folder on a server or in a shared online location, you'll only need to complete these steps once on one of your office's Land F/X workstations.