Unable to Find the Correct Pipe Class (How to Clear the Pipe Class Cache to Show Newly Added Pipe Classes)
Issue
You're unable to find the correct pipe class to use in your irrigation system.
You may have recently requested that we add a new pipe class to our system, but then tried to use that class and couldn't find it in the list of pipe classes we offer.
Cause
Your pipe XML cache needs to be cleared so the software can download the proper classes for your use.
Solution
1. Open your Irrigation Preferences and confirm the pipe class that's set in the Pipe Classes menu, such as US IMPERIAL or BRITISH METRIC.
2. Save your drawing and close CAD.
It's important to close CAD before moving on to the next step.
3. Navigate to your LandFX folder, and open the xml.cache folder within the location LandFX\data.
Delete the proper pipe class xml file in that location. The file name will start with P and, depending on the class type, might include -B, -M, -A, etc.
For example, if you have US IMPERIAL set in the Pipe Classes menu in your Irrigation Preferences, you'll be looking for and deleting the file P.xml.
If you have BRITISH METRIC set, you'll delete the file P-B.xml.
4. If you're trying to update an existing pipe class within a pipe category, delete the XML file in that same location whose name includes that same prefix and the corresponding pipe class.
For example, if you're trying to update the schedule 40 class within US IMPERIAL, you'll locate and delete the file P-PVC40.xml.
5. Open CAD, then open our Pipe Data tool. The new pipe class XML files will download automatically.
If you still don't see the pipe classes you need, send us a request in a technical support ticket, and we can help diagnose what may have happened.