Land F/X 3D Connection Plugin Becomes Unresponsive or Freezes
Issue
The Land F/X 3D Connection plugin is freezing or is otherwise unresponsive.
Cause
Improvements to the plugin can sometimes result in improvements to our supplied components as well. In these cases, the old blocks may no longer be compatible and need to be upgraded to the newest versions.
Don't worry! When updating components, we make every effort to maintain their original appearance so your existing models aren't affected.
Solution
1. In the Land F/X plugin inside SketchUp, take note of your library location using the Settings tool.
2. Using Windows Explorer, go to the folder shown as your Library Location.
In our example, the SketchUp library is assigned to the folder Documents\sketchup_library.
If you have any custom SketchUp symbols, copy this entire library folder to a temporary location – the desktop of your computer, for example. You'll be deleting the default Land F/X symbols and folders from the original library folder, and this step will give you a backup of your custom symbols.
3. Within the library folder, delete the following folders:
- Groundcovers
- Shrubs
- Site Amenities
- Trees
If you have custom symbols within the Land F/X default folder structure, you've safely made a backup of those symbols by copying your library to a temporary location in Step 2 above. You can return those symbols to their original locations in your library shortly.
4. Open the Slides folder in your SketchUp library. Delete all JPG files within this folder.
5. Restart SketchUp.
6. Open a Land F/X project in a blank SketchUp model, and try to place trees and shrubs, and change components. You may notice an initial lag, but the blank window effect shouldn't last more than 15 seconds.
7. If you have custom SketchUp symbols, open the copy of your SketchUp library folder you copied to a temporary location, such as your desktop, in Step 2 above. Locate your custom symbols, and move them to their original locations in your SketchUp library folder.
For example, you might have a folder named my_symbols within the trees folder that contains your custom tree symbols. Drag this folder from the Trees folder within the copy of your SketchUp folder on the desktop to the Trees folder within your original SketchUp library.
Even though you will have deleted the subfolders Groundcovers, Shrubs, Site Amenities, and Trees from your original SketchUp library folder, these subfolders will download automatically when you place a plant or site amenity symbol from the corresponding category. These newly downloaded folders will contain files for the new symbols you place, which will also download automatically.