Unable to Verify If This Site Has a Valid Support Contract (Academic Users)
Issue
You saw the following error message: Unable to verify if this site has a valid support contract.
Cause
This error pops up for Academic License users – such as college or university students or faculty. The error occurs when your school's Academic Support ID has changed since you last installed.
Each school using Land F/X receives a unique Support ID each academic year. The Support ID is only valid for that year, but students can still qualify for the free academic license for as long as they are a full-time student. Students need to re-apply each year to access the new Support ID.
Solution
To use Land F/X, you'll need to fill out the Academic License form again from our Academic Licensing page. Once you fill out that form, you'll receive an email with the latest Support ID and instructions on how to reactivate.
When filling out the academic licensing form, make sure you provide your official school email address (if you have one). You should receive an email with these items immediately after filling out the form correctly. Don't see the email? Check your junk or spam folder.