Question Marks (?) / Damaged or Missing Icons Appearing in Place of Land F/X Tool Icons in Land F/X Ribbons or Quick Access Toolbar
Issue
You see question marks (?), damaged icons, or missing icons instead of your Land F/X tool icons on your Land F/X ribbons ...
... or on your Quick Access Toolbar, as pictured below.
Important: Do not uninstall Land F/X when you encounter this issue! Uninstalling will lead to a whole new set of issues. If you experience this issue, please follow the steps outlined below.
Cause
Your Land F/X Workstation installation has become corrupted.
Solution
Step 1: Uninstall the Land F/X Workstation component.
Follow our steps to uninstall Land F/X Workstation .
Step 2: Run our latest F/X Workstation installer.
Follow our steps to download our latest Land F/X Workstation installer (setup_FXWorkstation) and run it from your LandFX folder.
After running the installer from your LandFX folder, you may need to load your Land F/X menus.
You should now be able to see your Land F/X tool icons within your ribbons.
AutoCAD ribbons (Light theme)
Land F/X ribbons (Light theme)
Still seeing question marks instead of your icons? Move on to the next step.
Step 3 (if necessary): Delete any versions of the file landfx.cuix in incorrect locations.
Open Windows Explorer, and type landfx.cuix into the search box.
The file landfx.cuix should only be located within the two following paths:
• C:\Users\your username*\Appdata\Roaming\Autodesk\AutoCAD20xx**\Rxx.x**\enu\Support
* Your computer username
** These exact folder names will vary depending on your year version of CAD
• C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx**
** This exact folder name will vary depending on your year version of CAD
Important: You'll need to have hidden files and folders visible to navigate to these folder paths.
Do you see any versions of the file landfx.cuix that are NOT within the two folder paths shown above?
If so, delete these files. Do not delete the landfx.cuix files from the folder paths shown above.
If you don't see a landfx.cuix file in the folder path pictured below, you'll need to add it back to the Support File Search Path.
To access the Support File Search Path, open the Options dialog box:
Manage ribbon, Options button
type Options in the Command line
right-click in the Command line and select Options from the menu
Tools pull-down menu
Select the Files tab.
Click the plus (+) sign next to the Support File Search Path entry.
The Support File Search Path will expand, revealing the folders listed in the path.
Look for the path C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx*.
Where >*20xx is your year version of CAD
Don't see this path in the Support File Search Path? Add it back:
1. Click Add.
2. Click Browse, and browse to the path listed above.
3. Click Apply to save the change.
Restart CAD.
Still seeing question marks in place of the ribbon icons? If so, open the Options dialog box again, and check for the path C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx* in the Support File Search Path.
If this path is no longer in the Support File Search Path, a custom LISP routine may be setting your Support Paths at startup, you'll need to add the path to your routine.
After addong the path to your routine, restart CAD again. If the path is still missing from the Support File Search Paths, check for any other CAD plugins loading and remove them. Then restart CAD and test again.
If the path is still missing after you've restarted CAD and made the change described above, create a new Windows user profile and check whether the issue persists under that account as well.
Is the issue resolved now?
- Yes: Migrate your (or the CAD user's) existing data over to the new profile. Here's how to do that.
- No: Move on to the next step in this article.
Close
Still don't see your icons, or receiving an error message? Move on the next step.
Step 4 (if necessary): Install the F/X Workstation component manually.
If you're still seeing question marks in place of your icons, or receiving an error message, complete our manual Workstation installation instructions.
If you still don't see your icons, or if you're receiving an error message at this point, move on to the next step.
Step 5 (if necessary): Delete the LandFX.mnr file.
Open the following folder:
C:\Users\your username*\Appdata\Roaming\Autodesk\AutoCAD20xx**\Rxx.x**\enu\Support
* Your computer username
** These exact folder names will vary depending on your installation of CAD
Important: You will need to have hidden files and folders visible to navigate to this folder path.
Within that folder, delete the file landfx.mnr.
This file will be re-created when you reopen AutoCAD.
Still not seeing the icons on the Quick Access Toolbar? Move on to the next step.
Step 6 (if necessary): Delete and re-add icons on the Quick Access Toolbar.
6A. Right-click one of the question marks on the Quick Access Toolbar.
6B. Select _Remove from Quick Access Toolbar from the menu that opens.
Repeat steps 6A. and 6B. for each question mark icon on your Quick Access Toolbar.
Repeat Steps 4 and 5 for each icon you want to add back to the Quick Access Toolbar.
Still not seeing the icons? Move on to the next step.
Step 7 (if necessary): Reset CAD to the default settings.
If you tried all previous steps and you're still not seeing the icons, you can resolve the issue by resetting CAD to the default settings.