AutoCAD Civil 3D Crashes or Freezes When You Open a Drawing
Issue
AutoCAD Civil 3D is crashing or freezing when you open a drawing.
You might also see the following error message: Runtime Part Parameter Configuration Error - Parameter Name = CLoc.
Cause
This is a known performance issue with AutoCAD Civil 3D that prevents drawing files from opening.
Solution
You can resolve this issue by installing the Civil 3D update (versions 2018 and newer) or Service Pack (versions 2017 and older).
Offices with multiple CAD users:
All CAD users in your office will need to complete the steps on this page. If the drawing is opened on a computer where the fix hasn't been applied, the issue will recur.
1. Close Civil 3D and all other CAD applications.
2. Verify that you have administrator rights on your computer.
3. Apply the update or Service Pack for your version of Civil 3D:
2018
Apply the latest update from the Autodesk Desktop App, now known as Autodesk Access.
2017 and older
Follow the official Autodesk instructions to download and install the Service Pack for your version.
4. Open and save the drawing file that is causing Civil 3D to freeze. Also open and resave all Xrefs and data shortcut source files.
This performance improvement will not apply to a file until that file is saved in Civil 3D with the update or Service Pack installed. The drawing file and all these additional files will open slowly when first opened after the fix is applied. Once you save a file after applying the update or Service Pack, the file size will decrease and the file will open more quickly.