You Must First Save the Block into the Plan Graphics Library Using the Save Block Tool (Editing or Viewing Information on a Plant Symbol or Other Block)
Issue
While attempting to edit or view information on a block in your drawing using our View Data tool, you received the following error message:
You must first save the block into the Plan Graphics library using the Save Block tool.
This issue can apply to editing or viewing information about:
- Irrigation equipment using our View Data tool
- Editing site blocks using our Block Data tool
Cause
This error can be the result of corruption in your drawing. It's possible that you've dismissed an extremely important message: Land F/X has detected corruption in this file: RegApps. This message informs you that you have corrupted objects in your drawing. If you ignore this message, those RegApps can corrupt the Land F/X data connected to your site blocks or irrigation equipment. More info on this message >
What is drawing corruption? Find our by reading our Drawing Corruption Explained page.
If you're seeing the You must first save the block ... message when attempting to edit irrigation equipment, it could also be that the equipment was not placed by using the Irrigation Manager.
Solution
1. Follow our steps to clean your drawing and all Xrefs.
These drawing cleanup steps can save you countless hours if you make it a habit to complete them each time you open a drawing from a co-worker or another consultant.
2. Place another instance of the block that caused the error. (Just place it off to the side. You can delete it later.)
In this example, we'll assume the error popped up when we placed one of the valves pictured to the right. We'll place another instance of the same valve.
4. When prompted to Select a source object, select the block you just placed.
In our example, we'll select the extra valve we placed off to the side.
5. When prompted to Select a destination object, select the block you were originally trying to edit.
6. If you've placed the same block more than once, you'll be asked whether you want to apply the change to all instances of that block.
Click Yes.
All instances of the problematic block in your drawing will be replaced with the version you just placed. Because you placed a fresh version of the block, you should now be able to edit any of those blocks without generating the error.
7. Delete the block you placed off to the side.
Still getting the error, or otherwise having trouble viewing the data attached to your blocks? Move on to the next steps.
1. Download the convert_appname_lsp.zip file linked below.
2. Double-click the downloaded file to unzip it. Move the unzipped file into your LandFX folder.
3. Restart AutoCAD or F/X CAD.
4. Copy the following text and paste it into the Command line: (load "convert_appname")
Make sure to include the parentheses in the copied and pasted text.
5. Select one of the blocks that are not being recognized. The system should go through and repair all Reg Apps.
These steps may not fix the objects. If so, restart AutoCAD again. Then place the problematic objects again.