Issue
When you attempted to license (activate) F/X CAD or AutoCAD, the activation dialog box opened briefly, the AutoCAD dialog box behind it turned white, and the program froze.
You may then have seen an Autodesk component has stopped working message like the one pictured to the right.
Cause
Autodesk has acknowledged this issue as a known bug caused by Windows updates, which have been conflicting with AutoCAD installations.
You can find the official Autodesk solution to this issue here.
Solution
Step 1: Run the Windows updates.
Step 2: Update your video card driver.
Step 3: Try activating again. If AutoCAD or F/X CAD is still freezing and/or you're still seeing the error message, move on to Step 4.
Step 4: Remove and reinstall the Microsoft Visual C++ Runtime Libraries
You may need your IT administrator to help you complete this step.
1. Open your computer's Control Panel and select Programs and Features.
2. In the Programs and Features screen, uninstall each file whose name starts with Microsoft Visual C++.
To do so, select each of these files and click Uninstall.
3. Download and install all of the files linked to the right, one at a time.
Take care to download and install both the x64 and x86 versions of each of these files if you have a 64-bit operating system. The file names for both of these versions of each each file will be the same – take care not to overwrite any of these files you've already downloaded with the other version of that file.
- Microsoft Visual C++ 2005 SP1 Redistributable (x86)
- Microsoft Visual C++ 2005 SP1 Redistributable (x64)
- Microsoft Visual C++ 2008 SP1 Redistributable (x86)
- Microsoft Visual C++ 2008 SP1 Redistributable (x64)
- Microsoft Visual C++ 2010 SP1 Redistributable (x86)
- Microsoft Visual C++ 2010 SP1 Redistributable (x64)
- Microsoft Visual C++ 2012 Update 4 Redistributable (x86 and x64)
- Microsoft Visual C++ 2013 Redistributable (x86 and x64)
- Microsoft Visual C++ 2015 Redistributable (x86 and x64)
Note that only the x86 versions of these files will work on 32-bit operating systems. Not sure whether you have a 64- or 32-bit system? Here's how to find out.
You should now be able to activate AutoCAD or F/X CAD successfully.
Still not able to activate? You may need to create a new Windows profile in order to activate successfully.