Revert to a Previous Version of Land F/X After an Update / Application Appears to Be Damaged
Issue
You're experiencing problems resulting from a Land F/X update. The update either didn't complete or contained a bug that's preventing you from working.
In the interest of completing work or meeting a deadline, you need to revert to a previous version of Land F/X.
You may have also seen the following error message:
The Land F/X application appears to be damaged. I will bring up an article to address this.
If so, you can resolve the issue by following the steps in this article.
Cause
As with any other software, Land F/X updates can, on occasion, result in bugs. Although we are extremely vigilant about repairing bugs in our updates – and can often fix them in a matter of minutes or hours – you may need to complete work in the interim. Or you might be in a time zone where you are unable to get ahold of us during our normal business hours. In the meantime, the update bug is making it difficult or impossible to complete your work.
Solution
You can get back to work right away by simply reverting Land F/X to an older version. First, which of the following updating issues are you experiencing?
- The update failed to complete. If so, first try the LOL / VR command.
- The update completed successfully, but it includes a bug that is preventing you from working. If so, revert manually to the previous version.
Update failed to complete? Run the LOL / VR command.
The following steps should revert your installation to the last version before the update, allowing you to try updating again.
1. Type LOL in the Command line and press Enter.
2. Type VR in the Command line and press Enter.
3. Restart CAD.
4. Did CAD fire up correctly? Open our Update tool, and run the update again.
Still having problems updating? Or does the update appear to include a bug that's preventing your from working? Follow the steps below to revert your version manually.
Bug in the update? Revert your version manually
To revert your version of Land F/X manually in order to resolve a bug in an update, you'll need to open your LandFX folder and change the name of a specific file.
Your LandFX folder will be on your C: drive if you have a standalone installation (without an office server). If your office has Land F/X installed on a computer functioning as a central server, your LandFX folder will be on that computer. If you are unsure of the location of your LandFX folder, or do not have access to folders on your office server, please contact your IT administrator.
Step 1: Turn on file name extensions.
Follow our steps to make file extensions visible.
Step 2: Find the VLX files.
Within your LandFX folder, locate the following files:
- LandFX.vlx
- LandFX.vlx.bak
You will not see these files properly unless you've completed the previous step, making file extensions visible.
Step 3: Rename the VLX files.
Rename the two VLX files in the following order:
1. Rename the file LandFX.vlx, giving it the name LandFXold.vlx
2. Rename the file LandFX.vlx.bak, giving it the name LandFX.vlx.
Renaming the files in this way will revert your Land F/X installation back to the version you were using prior to the update. You should now be able to complete work using Land F/X while we work to repair the update.
We pride ourselves on our responsiveness to update bugs, and we are generally able to repair them quickly with a new update. You can usually count on a new update to repair the issue within a few hours – if the bug occurs during our business hours. If not, it may take us a day or two to carry out the repair. However, in the meantime, you should be able to work again once you've reverted to the older version.