Pipe Data Additions or Changes are Not Saving in Projects or Preferences
Issue
You're attempting to add or edit pipe classes in your Pipe Data default settings or your project Pipe Data, but the data is not saving.
Cause
A duplicate or errant pipe entry in your Irrigation Preferences Pipe Data is loading into your project Pipe Data at the start of each project and preventing any new data from being saved.
Solution
Step 1: Amend the Preference Set data to prevent this issue in the future.
Because the Pipe Data is pulled from your Preference Set Pipe data defaults at the creation of each new project, you'll need to correct the Pipe Data stored within the Preferences first in order to prevent this issue in future projects.
1A. Open our Projects tool:
F/X Admin ribbon, Project List button
or type FX_ProjectFiles in the Command line
F/X Admin pull-down menu
1B: In the Project List dialog box, click Backup.
In the Backup Project dialog box, select the option to Backup all projects and Preference Sets, then click OK.
1C: Make note of all Pipe Data defaults in your Preference Sets and your Pipe Data in your projects so you can reference it when re-inputting the information.
If you're experiencing this issue with a particular Preference Set, make note of the name of that Preference Set.
1D: Navigate to the folder LandFX\data\backup. Open the subfolder named with the date of your backup. (For example, if you backed up your projects and Preference Sets on June 26, 2024, you would open the subfolder 2024-06-26.)
Locate the backup file named for the Preference Set in which you're experiencing the issue, and open it with a text editor application such as Notepad.
1E: Search for the word MAINPIPE or LATPIPE in the open Preference Set text file.
1F: Select from the first <projdata> entry down to the </projdata> after the last entry of Main Line Pipe, then delete the selected text.
This step will delete all entries of Lateral Line Pipe and Main Line Pipe from the text file.
1G: Close and save the Preference Set file.
1H. Open the Project List again, and click Restore. When prompted, click the option to overwrite the existing Preference Set.
Step 2: Repair any projects experiencing this issue.
2A: Locate and open the file in your LandFX\data\backup folder for every Land F/X project experiencing this issue.
2B: Complete steps 1E. through 1H. in all project files where you are unable to save Pipe Data.
2C: After fixing and restoring the new Preference Set and project files, remember to re-enter your Pipe Data in the affected projects and Preference Sets.