All of Your Licenses are Currently in Use
Issue
You received the following error message when attempting to use one of our plugins:
All of your licenses are currently in use. Please check the Preferences screen to see which stations have them locked.
Cause
As the error message indicates, all licenses in your office or network are being used. To use our software, you'll need to locate a license on your network and check it out on your computer.
You may also be using an incorrect Support ID, which would prevent you from checking out a license.
Solution
Step 1: Check Your License Installation in the General Preferences
Open the General Preferences screen:
F/X Admin ribbon, General button
FX Admin toolbar
type *FXPreferences in the Command line
Select the Preferences option from any of the F/X pull-down menus (F/X Admin, F/X Site, F/X Planting, F/X Irrigation, or F/X Details)
The General Preferences screen shows which versions of our software, if any, you currently have checked out on your computer. Under License Information, you'll see the following three listings, which represent our three software modules:
- DFX (Design F/X)
- PFX (Planting F/X)
- IFX (Irrigation F/X)
Each of these listings will be followed by a number, which represents the number of licenses of that software module you currently have checked out on your computer. If all three are followed by a 0, you'll know that you do not have a license checked out.
If this is the case, you'll need to check out a license from our License Manager.
Do you see the correct number of licenses checked out for your computer at this point, but the All of your licenses are currently in use error keeps popping up? For example, let's say you are supposed to have a Design F/X (DFX) license checked out, and you see a 1 under the IFX entry in the General Preferences (as you're supposed to) – but you're still getting the error message.
If so, you may be able to resolve the issue by simply opening the License Manager and clicking Save Changes.
Step 2: View Available Licenses and Check Out a License
Click the Licenses button in the General Preferences to view the available licenses in your network or office.
The License Manager will open. The list of Installed Licenses will include an entry for your computer (current installation), which will be highlighted in yellow. This entry will also list the number of Design F/X, Planting F/X, or Irrigation F/X licenses that are currently checked out to your computer. You will likely see a 0 in each of these columns, indicating that you do not have a license checked out.
At the top of the License Manager, you'll see the number of available licenses for each of the three modules.
If you don't have a license checked out, you'll need to follow our steps to check out a license for Design F/X, Planting F/X, or Irrigation F/X.
Unsure of whether you should be checking out Design F/X Planting F/X, or Irrigation F/X? Don't know what kind of licensing your office has? Your network administrator should be able to tell you this information.
Step 3 (If Necessary): No Licenses Available? Verify Your Support ID
If you don't see any licenses available on your network, you may be using an incorrect Support ID. Verify your Support ID in the General Preferences.
You or your office will have received the Support ID in an email from Land F/X. Check this email, or ask your network administrator for the correct Support ID. If you are using an incorrect Support ID, you'll need to reactivate Land F/X and enter the correct Support ID.
If you are still unable to use the software, you may still have to check out a license.