Unable to Initialize ADLM – Error Code -4104 (Opening AutoCAD or F/X CAD)
Issue
When opening F/X CAD or AutoCAD, you received the following error message:
Unable to initialize adlm.
Internal Error Message: <Error initializing the Usage tracking component.>
Error Code: <-104>
Cause
This error is the result of a problem with the Autodesk License Manager (ADLM).
Solution
1. Follow our steps to reinstall AutoCAD or F/X CAD. This step will repair your installation without removing your custom settings.
Still getting the error? Move on to the next step.
2. Delete the .data file from each of the following locations:
- C:\ProgramData\FLEXnet\adskflex_00691b00_tsf.data
- C:\ProgramData\FLEXnet\adskflex_00691b00_tsf.data_backup.001
AutoCAD or F/X CAD should auto-activate as a result.
3. If CAD does not auto-activate, activate CAD manually:
- Activate F/X CAD (select the option for your year version of AutoCAD or F/X CAD).
- Activate AutoCAD.
4. Start AutoCAD or F/X CAD from the shortcut on your desktop.
Still getting the error? Move on to the next step.
5. Rename the folder C:\Program Files\Common Files\Macrovision Shared, giving it a name such as C:\Program Files\Common Files\Macrovision Shared2
6. Follow our steps to reinstall AutoCAD or F/X CAD again.
Still getting the error? Move on to the next step.
7. Double-click the file LMU.exe from within the folder C:\Program Files\Common Files\Autodesk Shared\AdLM\RXX (where XX is a number specific to your version, such as 14 or 12).
You may also need to double-click the file FNPLicensingService64.exe from within the folder C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher.
8. Locate the folder ADUT within each of the following folders.
- C:\Users\<username>\AppData\Roaming\Autodesk\
- C:\ProgramData\Autodesk\
Rename both ADUT folders, giving them names such as ADUT2.
9. Set the FlexNet Licensing Service 64 to automatic:
- Open the Windows Command Prompt and type services.msc
- Locate and right-click FlexNet Licensing Service 64 from within the list.
- Under Startup Type, select Automatic.
- Click Apply, then click OK.
- Right-click again, and select Restart.
10. Open CAD again.
If you're still getting the error, the next step is to uninstall and reinstall CAD.
Uninstalling is a drastic measure that removes your custom settings. Before going through the Uninstall/Reinstall steps, make sure you've tried everything else on this page. You may want to send us a technical support ticket describing your issue before resorting to an uninstall.