Error: "Base.dcl" Can't Find File /Error Loading Dialog Control File / Semantic Error(s) in DCL File / Error in Dialog File (Installing Land F/X or Opening AutoCAD or F/X CAD)
Issue
You saw the following error message when installing a Land F/X plugin, or when opening AutoCAD or F/X CAD:
"Base.dcl"
Can't find file.
You might also see one or more of the following error messages:
Error loading dialog control file.
Semantic error(s) in DCL file
See file acad.dce for details.
Error in dialog file
warning: redefining object.
Symbol: "confirmbox".
Cause
This error can result from the accidental deletion of a particular entry in your Support File Search Path. It can also result from a damaged AutoCAD Roaming Support folder that needs to be re-created.
Solution
To address this error, open the AutoCAD Options dialog box:
Manage ribbon, Options button
type Options in the Command line
right-click in the Command line and select Options from the menu
Tools pull-down menu
The Options dialog box will open.
Select the Files tab, then expand the Support File Search Path item by clicking the plus (+) sign next to it.
In the expanded Support File Search Path folder, the top entry should be: C:\Users\*username\AppData\Roaming\Autodesk\AutoCAD 20xx\RXX.X\enu\support
(where *username is your Windows username, 20xx is your version of AutoCAD, and RXX.X is the name of the single folder in your AutoCAD version folder)
If the top entry in the Support File Search Path is NOT the path shown above, you'll need to complete the following steps to correct the issue.
1. Ensure that your hidden files and folders are turned on.
2. Once you're sure that your Hidden and System files are turned on, click Add. Then click Browse.
3. The Browse for Folder dialog box will open.
Scroll down and expand the entry for This PC (if you have Windows 10) or Computer (if you have Windows 7).
Then expand the Local Disk (C:) entry.
4. Once you've expanded the Local Disk C: entry, expand the following entries:
- Users
- your username (example: Jason)
- AppData (Note: you won't see this folder unless you have your hidden files and folders enabled.)
- Roaming
- Autodesk
- AutoCAD 20xx (where 20xx is your version of AutoCAD or F/X CAD)
- Rxx.x (The exact name of this folder will vary depending on your version.)
- enu
Then highlight the folder Support and click OK.
This folder tree will be added to the Support File Search Path.
5. The Support File Search Path will now include the folder tree you added:
C:\Users\*username\roaming\autodesk\autocad 20xx\rxx.x\enu\support
Select this folder tree and click Move Up.
6. Continue to click Move Up until the folder tree is at the top of the list.
Then click OK to save the change.
7. Close and restart CAD. If you don't see an error message and you can use our software without further issue, you've resolved the problem.
Still getting an error, or is the software otherwise not functioning correctly? If so, move on to the next step.
8. Open the Options dialog box again, and look for the path you just added (C:\Users\*username\roaming\autodesk\autocad 20xx\rxx.x\enu\support) in the Support File Search Path.
If you don't see the path, your next step should be to check ownership on the following folder: Users\*username\AppData\Roaming\Autodesk (where *username is your actual computer username.) Follow our instructions to check and change ownership of folders in Windows.
The owner of that directory and all subdirectories should be SYSTEM. If it's anything else, use the steps linked above to change the owner to SYSTEM.
9. After taking ownership of the folder path, you'll see a check box to Replace owner on subcontainers and objects. Check this box, then click OK to close the dialog box.
10. Repeat the steps above to add it back to the Support File Search Path.
11. Close and restart CAD. If you don't see an error message and you can use our software without further issue, you've resolved the problem.
Still getting an error, or is the software otherwise not functioning correctly? If so, move on to the next step.
12. Open the Options dialog box again, and look for the path you tried to add (C:\Users\*username\roaming\autodesk\autocad 20xx\rxx.x\enu\support) in the Support File Search Path.
If the path is still missing, your AutoCAD Roaming Support folder is damaged. Your next step should be to follow our instructions to reset your AutoCAD profile.