License Error: The License Manager is Not Functioning or is Improperly Installed (FLEXnet Error)
Issue
You saw an error message similar to the following when attempting to launch AutoCAD or F/X CAD:
License Error: The License manager is not functioning or is improperly installed. AutoCAD will shut down now.
If you're running F/X CAD 2021 or newer, the error might read similar to the following:
License Error: The License manager is not functioning or is improperly installed. AutoCAD will shut down now.
ADLSDK_STATUS_AUTH_PENDING
20:Generic license checkout error
Cause & Solution
Your cause and solution will depend on your version of CAD:
AutoCAD or F/X CAD 2022 & newer
If you're using the 2022 or 2023 year version, this error can result from:
- A compatibility issue between sleep mode and the Autodesk Desktop Licensing Service (AdskLicensing) 11.1 update, or
- Licensing services timing out on your computer
Here's your solution:
Step 1 (2022 & newer): Install the most recent Autodesk Licensing Service update.
1A. Download the latest update.
1B. Open Windows Explorer and navigate to the location C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing on your computer.
Right-click the file uninstall.exe and select Run as administrator from the menu that opens.
This step will uninstall the Licensing Service.
Skip this step if the AdskLicensing folder is empty.
1C. Disable any antivirus software or firewall temporarily.
1D. Open the software installation folder for your 2022 year version of CAD. This folder should be in the location C:\Autodesk by default.
1E. Locate the file AdskLicensing-installer.exe, which you downloaded in Step 1A above. This file will usually be in the location C:\Autodesk\ ... \x86\Licensing<
1F. Run (double-click) the file AdskLicensing-installer.exe.
1G. Open CAD and verify that it's functioning correctly.
Still getting the error when your computer goes into sleep mode? If so, move on to the next step.
Step 2 (2022 & newer): Increase the time before your computer goes into sleep mode.
2A. Open the Windows Start menu and search for Sleep.
Select the option Change when the PC sleeps from the menu.
2B. Use the two menus to increase your computer's sleep time, or set both menus to Never.
Step 3 (2022 & newer): Check whether third-party software is conflicting with the Autodesk Licensing Service.
See our article on applications and devices known to conflict with the Licensing Service.
If you have one of the listed applications or devices on your computer, follow the solution steps for that product as covered in the article.
Step 4 (2022 & newer): Change services to Automatic (Delayed Start)
4A. Open the Windows Start menu and search for Services.
Select the Services option from the menu.
4B. Verify that the following services are running:
- Autodesk Desktop Licensing Service
- FlexNet Licensing Service
Locate and click each service in the menu, and verify that the Service status is set to Running. (Autodesk Desktop Licensing Service pictured as an example below.)
If either (or both) services is not running, click the Start option to start it.
For each service, select the Automatic (Delayed Start) option from the Startup type menu.
AutoCAD or F/X CAD 2021
If you saw this error and you're using AutoCAD or F/X CAD 2021, it may be happening because:
- A compatibility issue between the Autodesk Licensing Service and your computer's sleep mode is preventing the License Manager from functioning correctly, and/or
- CAD is repeatedly attempting to load the license terms acceptance dialog on launch but is unable to do so because the agreement has not been accepted.
To resolve this issue for the 2021 year version:
1. Close CAD.
2. Follow our instructions to disable sleep mode on your computer.
Open CAD again. Still getting the error? If so, move on to the next step.
3. Open the folder C:\ProgramData\Flexnet on your computer.
You'll need to have hidden files and folders visible to navigate to this folder.
4. Delete all files within that folder.
5. Restart CAD.
You should now be able to open AutoCAD or F/X CAD without seeing the error.
AutoCAD or F/X CAD 2020 or older
Are you running AutoCAD or F/X CAD 2020 or older, and did you see the error after clicking something other than Run, Activate, or Repair in the Autodesk Licensing screen, pictured to the right? If so, you can resolve the issue by clicking Run, Activate, or Repair if your license is damaged.
The button on the right side of the dialog box may read Activate or Repair, depending on your license condition.
Still getting the error? The cause of, and solution to, the error will depend on your year version of AutoCAD or F/X CAD.
Cause
This error can occur because:
- The file C:\ProgramData\Autodesk\AdskLicensingService\AdskLicensingService.sds has become corrupted, or
- A third-party Web browser protection application may be blocking the activation screen.
Solution
Complete each of the following steps one at a time, attempting to open your CAD platform after each one. If any of these steps do not apply, skip to the next one.
Step 1: Update Autodesk Licensing Service
1A. Download the Autodesk Licensing Service - 9.0.3.46 - April 2019 Hotfix from this page.
1B. Double-click the downloaded hotfix to install it. Then restart your computer and attempt to open AutoCAD or F/X CAD 2020 again.
Still getting the error? Move on to the next step.
Step 2: Address issues with LogMeIn (only if you have LogMeIn installed)
2A: Disable the LogMeIn display adapter
If you have LogMeIn installed, open your Start menu and type Device in the search box.
Select the Device Manager option from the top of the menu.
Double-click Display adapters to expand that section.
If you see an adapter related to LogMeIn here, right-click it and disable it.
Open AutoCAD or F/X CAD 2020.
Still getting the error? Move on to the next step.
2B: Shut down any processes related to LogMeIn
Open your Start menu and type Task into the search box.
Select the Task Manager option from the menu.
Select any processes related to LogMeIn within the Task Manager, and click End task.
Open AutoCAD or F/X CAD 2020.
Still getting the error? Move on to the next step.
Step 3: Check whether the Autodesk Desktop Licensing Service is running
3A. Press the Windows + R keys (Windows keyboard) or Command + R keys (Mac keyboard) to open the Run dialog box.
Type services.msc in the text field, and click OK.
3B. Locate the Autodesk Desktop Licensing Service entry in the Services dialog box, and check whether it's listed as Running in the Status column.
If you don't see Running in this column, right-click the Autodesk Desktop Licensing Service entry and select Properties from the menu that opens.
If this service is already listed as Running, move on to Step 4.
3C. In the Properties dialog box, open the Startup type menu and select the Automatic (Delayed Start) option.
Then click OK.
3D. If the Autodesk Desktop Licensing Service service is still not running, select it and click Start the service.
3E. If the service starts successfully, open AutoCAD or F/X CAD 2020.
Still getting the error? Move on to Step 4.
Go to the folder C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.
Right-click the file uninstall.exe, then select Run as administrator from the menu that oopens.
Now navigate to the folder C:\ProgramData\Autodesk\AdskLicensingService.
Move the files in that location to a different folder, such as a temporary folder you've created on your desktop.
To view this folder, you'll need to verify that your hidden files and folders are visible.
Restart your computer.
Disable the following items temporarily:
- User Account Control in Windows
- Any antivirus software
Your IT administrator may need to assist with this step.
Navigate to the Autodesk 2020 product install folder, then open \x86\AdskLicensing.
F/X CAD 2020 users: This path will be C:\Users\[UserName]\Appdata\Local\Temp\fxcad2020.64\x86\AdskLicensing. You'll need to have your hidden files and folders visible to navigate to this folder.
AutoCAD 2020 users: This path will be C:\Autodesk\AutoCAD_2020_English_win_64bit_dlm\x86\AdskLicensing.
Right-click the file AdskLicensing-installer.exe, and select Run as administrator from the menu that opens.
Allow a few minutes for the installation to complete.
Install the most recent updates for Autodesk Licensing Service from either:
- The Autodesk Desktop App, or
- From the Product Updates section of your Autodesk account portal
Open your Start menu, and type CMD in the search box.
Right-click the Command Prompt option in the menu. Then select Run as administrator.
Copy and paste the following text at the command prompt:
cd C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\helper\
AdskLicensingInstHelper register -pk 001L1 -pv 2020.0.0.F -cf C:\Autodesk\AutoCAD_2020_English_win_64bit_dlm\Setup\AutoCADConfig.Pit -el US
Then press Enter.
The command listed above applies specifically to AutoCAD or F/X CAD 2020.
Open AutoCAD or F/X CAD again, and sign in if prompted.
Still getting the error? Move on to the next step.
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Step 4. Verify that the Common AppData string value key exists and has the correct value in the system registry
4A. Press the Windows + R keys (Windows keyboard) or Command + R keys (Mac keyboard) keys to open the Run dialog box.
Type CMD in the text field, and click OK.
4B. Type set ProgramData at the command prompt and press Enter. Take note of the value – for example, C:\ProgramData.
4C. Press the Windows + R keys (Windows keyboard) or Command + R keys (Mac keyboard) keys to open the Run dialog box again.
Type regedit in the text field, and click OK.
4D. Check whether the key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explorer\Shell Folders\Common AppData exists. (You can expand each key to check its contents by clicking the down-facing arrow to the left of its folder entry in the left pane.)
If this key does not exist, add the Common AppData string value key with the value from Step 6B above – for example, C:\ProgramData.
You may need your IT administrator's help with this step.
4E. Check whether the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Folders\Common AppData exists. Note: This key has a similar, but not identical, path to the key listed above.
If you don't see this key, add the Common AppData string value key with the value from Step 6B above – for example, C:\ProgramData – to this location as well.
You may also need your IT Administrator's help with this step.
4F. Restart your computer, then open AutoCAD or F/X CAD.
Still getting an error? Move on to the next step.
Step 5: Uninstall Autodesk 2020 software (only if the Install Now method was used to install AutoCAD)
This step does not apply to F/X CAD users.
5A. If the Install Now method was used to install AutoCAD on your computer, uninstall all Autodesk 2020 products from your computer.
5B. Download the complete software installer from Autodesk accounts portal using the Browser Download method.
5C. Install AutoCAD using the Autodesk-recommended installation method.
5D. Open AutoCAD or F/X CAD.
Still getting an error? Move on to the next step.
Step 6: Temporarily disable third-party Web browser protection
6A. If you have a third-party Web browser protection application such as K9 Web Protection installed, disable or uninstall it temporarily.
You may need your IT Administrator's help with this step.
6B. Restart your computer, then open F/X CAD or AutoCAD.
Still getting an error? At this point, your IT administrator may need to diagnose a deeper issue with your computer.
For further information, see the official Autodesk solution for this error.
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Cause
This error can have several possible causes, including:
- Skipping a step while activating F/X CAD
- A problem with the FLEXnet Licensing Service
- A corrupt LGS.data file
For more information, see the Autodesk article on this error message.
Solution
F/X CAD users: Have you purchased F/X CAD? Follow our steps to license (activate) F/X CAD, making sure to enter your Product Key and Serial Number. Activating will often resolve this issue. If you're certain that you've activated your installation successfully and you're still getting the error, complete the steps below.
Getting a Clock Error message?
You might see the following error message before seeing the licensing error: Clock Error: Check that your system clock is set to the current date and time before you try again.
If so, here's what to do.
Step 1: Ensure that the FlexNet Licensing Service is running.
1A. Open the Windows Start menu.
Type Run in the search field.
Select the Run option that appears at the top of the menu.
1B. Type services.msc in the Run dialog box, then click OK.
1C. The Services screen will open.
Scroll to the FlexNet Licensing 64 entry. Do you see Running in the Status column?
- Yes: Close the Services window and move on to Step 1D.
- No: Skip to Step 2: Check software restrictions.
1D. If the FlexNet Licensing 64 service is not running, right-click the word Manual in the Startup Type column to the right of this entry.
Select Properties from the menu that opens.
1E. In the Properties window, select the General tab and select the Automatic option from the Startup Type menu.
Click OK to save the change.
If necessary, you can start the FlexNet Licensing 64 service by right-clicking its blank entry in the Status column and selecting Start from the menu that opens. When the service is running, you'll see Running in the Status column.
Can't start the service? Your Windows profile may have insufficient permissions. If so, ask your IT administrator to grant you the proper permissions.
If you're using AutoCAD 2018 and can't start the service, install the Autodesk License Service (x64) - 5.1.5 Hotfix.
Step 2: Address software restrictions.
If the FlexNet Licensing 64 service is running but you still see the error when you open CAD, check to ensure that your CAD installation is able to access the domains listed in this Autodesk article.
Are you using a proxy server?
If you're using a proxy server, open Internet Explorer and click the gear icon in the top right corner of the window.
Select Internet Options from the menu that opens.
In the Internet Options dialog box, select the Connections tab.
Click LAN Settings. In the dialog box that opens, select the option to Automatically detect settings and enter the Proxy IP-Address + Port in the Address field.
Click OK to save the change.
If your proxy requires authentication, enter your Proxy and Credentials in the Autodesk Desktop App.
Step 3: Enable Active X controls.
Still getting the error? Here's what to do next.
3A. Open the Window Start menu and type Internet Options in the search box.
Select Internet Options from the top of the menu.
3B. In the Internet Properties dialog box, select the Security tab.
Click Custom level .... In the dialog box that opens, scroll down to the following two listings and select Enable for each one:
- Run ActiveX controls and plug-ins
- Script ActiveX control marked safe for scripting*
Click OK to save the change, then click OK in the Internet Properties dialog box to close it.
Step 4: Set folder permissions.
If you're still getting the error at this point, your next step should be to grant Full Control permissions to all folders and registries listed in our article on user permissions required by AutoCAD or F/X CAD.
After setting the folder and registry permissions, run your AutoCAD or F/X CAD installation as an administrator by right-clicking its icon and selecting Run As Administrator from the menu that opens. If it runs properly and you don't see the error, you've likely resolved the issue.
Step 5: Re-create the licensing data file.
5A. Close CAD (if it's still open).
5B. Navigate to the folder C:\Program Files\Autodesk\AutoCAD 20xx (where 20xx is your year version of AutoCAD or F/X CAD (AutoCAD 2019 shown as an example.
Double-click the file acad.exe from that location.
Attempt to open CAD from the location where you normally open it. If it opens and you don't see the error, you've resolved the issue.
Are you still seeing the error after launching CAD from the folder listed above? Move on to the next step.
5C. Close CAD again.
5D. Download the LGS.data file for your version of AutoCAD or F/X CAD using one of the following links.
5E. Double-click the downloaded file (it will be named LGS.data-2017, LGS.data-2018, or LGS.data-2019, depending on your version).
5F. The file will unzip and create a folder. Copy that folder into the following folder on your computer: C:\ProgramData\Autodesk\CLM\LGS\
5G. Open AutoCAD or F/X CAD. If you don't see the error, you've resolved the issue.
Still getting the error? Move on to the next step.
5H. Follow our steps to uninstall and reinstall your version of F/X CAD or AutoCAD.
5i. Start AutoCAD or F/X CAD. If you don't an error message, you've solved the problem.
Still seeing the error? At this point, your office IT administrator will most likely need to diagnose the issue and possibly reinstall Windows on your computer.
Step 6: Restore the CLM folder.
Still getting the error? Navigate to the folder C:\ProgramData\Autodesk\. In that location, change the name of the folder CLM to CLMold.
Now open the Control Panel and select Programs and Features. Repair the x64 version of each Microsoft Visual C++ Redistributable version you see installed by selecting that version, clicking Change, and then clicking Repair in the dialog box that opens.
If you also see one or more versions of the Autodesk Licensing Service (x64) in the Programs and Features dialog box, select each of those entries and click Change as well.
In this same location, right-click each Autodesk License Service (x64) version you see and click Change.
Open AutoCAD or F/X CAD. Still getting the error? Move on to the next step.
Step 7: Reactivate the license.
To complete this step, you'll need to be able to view hidden files and folders.
7A. Delete the files listed below from within each of the following folder locations:
- C:\Users\username*\AppData\Roaming\Autodesk\ADUT: Delete all files within this location.
- C:\ProgramData\FLEXnet:Delete all files in this location whose names start with adskflex.
- C:\Users\username*\AppData\Local\Autodesk\Web Services: Delete the file LoginState.xml from this location.
7B. Restart AutoCAD or F/X CAD.
7C. Navigate to each of the folder locations listed above. The files you deleted should have been re-created in those locations.
If the files you deleted were not re-created in these folder locations, here's what to do:
Open the Windows Start menu and type Internet Options into the search box.
Select Internet Options from the top of the menu.
In the Internet Properties dialog box, select the Advanced tab. Scroll down to the Security section and ensure that the Use SSL 3.0 option is selected.
Click OK to save the change and close the dialog box.
Follow our instructions to uninstall and reinstall the Microsoft Visual C++ Runtime Libraries.
Open your version of AutoCAD or F/X CAD, and try to activate it.
Unable to activate? follow our steps to uninstall and reinstall AutoCAD or F/X CAD.
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