Plant Schedule Showing Incorrect Plant Quantity or Square Footage/Meters
Issue
Your Plant Schedule is calculating your plants incorrectly. For example, it may be listing:
- The wrong plant quantities for a tree, shrub, groundcover, or Shrub Area
- The wrong square area (in feet or meters) for a groundcover, such as a sod or turf
In some cases, the schedule might be listing an exact fraction (or multiplication) of the number of plants it should be showing.
Is a plant in your schedule showing an extremely high quantity (hundreds or even thousands too many), which either should be much lower, or is not (or doesn't appear to be) a plant that is in your drawing at all? If so, Try this first.
Is your Plant Schedule missing one or more plant categories (Trees, Shrubs, Shrub Areas, or Groundcovers)?
Causes
Common causes include:
- An older drawing with legacy Shrub Areas from when the plant Xdata was on the boundary polyline instead of the hatch (Xdata was upgraded to be on the hatch back in 2017). Starting with version 19.14 (April 2023), these legacy Shrub Areas need to be upgraded to hatch Xdata because a schedule upgrade required legacy support to be dropped for these old Shrub Areas.
- A plant or group of plants mistakenly placed well off your intended site for your design.
- An invisible or exploded hatch object (for groundcovers or Shrub Areas).
- A polyline boundary of a groundcover or sod hatch that isn't properly closed, or is overlapping other polyline boundaries.
- Multiple plants with the same code (usually due to extensive edits – especially when using the same Land F/X project for multiple DWG files).
- Several possible issues with Xrefs – if you have other files Xrefed into your planting plan.
If your drawing has Xrefs attached to it, you might have encountered this issue after generating a Plant Schedule with the Include Xrefs option checked – a possible indicator of a problem with plants in your Xrefs.
- A planting area (a groundcover or Shrub Area) may have been edited and changed to a plant symbol (a shrub or tree), and the planting hatches that had already been already placed were not deleted.
Solution
If your Plant Schedule listing plants that aren't (or don't appear to be) in your drawing, try this solution first.
If your drawing includes Xrefs and you suspect that the issue is originating from one of those files, you may want to skip to Step 11 below and check your Xrefs for issues. Then, if your schedule is still showing the wrong quantities or areas, you can check your main drawing starting with Step 1.
1. Run our Verify Labels tool to upgrade any legacy Shrub Areas to hatch Xdata instead of polyline Xdata.
Still having issues with the schedule after running Verify Labels? If so, move on to the next step.
2. Type Zoom in the Command line and press Enter. Then type E (for Extents). Your view will now zoom out to the outer extents of your drawing.
Zooming to Extents is a great troubleshooting step for a number of issues you might be experiencing with your drawings. For more information, see our Zoom to Extents article.
3. Open the Plant Manager.
Select the plant that is being calculated incorrectly. Then click Highlight.
4. All instances of the selected plant will be highlighted in your drawing. While still zoomed to extents, look for highlighted plants outside the intended scope of your design. (They may just appear as small yellow dots.)
The example below shows a plan where a plant or group of plants (the dot in the tip right corner) has been placed well outside the intended site (the area in the bottom left corner). If you see any of these extra plants or planting areas, delete them.
Was nothing highlighted?
Or are the plants that were highlighted not explaining high quantities in the schedule? (For example, the schedule shows 17,000 shrubs but the Highlight tool only found 30?)
You might have a symbol plant (tree or shrub) that used to be a hatch plant (Shrub Area or groundcover), or vice versa. Our Highlight tool only looks for the same symbol type (block or hatch), so if you highlight a shrub, it won’t show any hatches with the same data still applied. To highlight and delete these plants:
1. Edit the problem plant from the Plant Manager.
2. Change the plant to the opposite symbol type. (For a shrub, change it to a Shrub Area. For a Shrub Area, change it to a shrub.) Click OK
3. Run the Highlight tool again. You should now find the problem shrubs. Delete them, or place a different hatch-type plant (groundcover or Shrub Area) in that location instead.
4. Edit the problem plant from the Plant Manager again.
5. Change the type back to the original category (Tree, Shrub, Shrub Area, or Groundcover).
6. Run your schedule to make sure it's counting all the plants.
5. Once you've deleted any plants from outside your intended site, run another Plant Schedule.
Are the quantities correct?
- Yes, the quantities are correct in the schedule: You've resolved the issue.
- No, the quantities are still incorrect in the schedule: Move on to the next step.
6. Create a new Work Area that includes a portion of your design – you'll use it as a test Work Area to isolate regions in your drawing to check for problematic plants.
7. Use the Highlight option from the Plant Manager (described above) on any plants that are calculating incorrectly in the schedule.
Scan the test Work Area to look for issues with the highlighted plants, such as missing or extra plants, or problems with hatches or hatch boundaries.
Also look for:
- Exploded or invisible hatch areas (groundcovers or Shrub Areas): Scan the Work Area for highlighted areas that don't appear to have a planting hatch. If you find any of these problematic hatch areas within your test Work Area, delete them. If necessary, place them again.
- Unclosed polyline boundaries (groundcovers or Shrub Areas): The hatch boundary of a planting area may not be closed. If you find a planting hatch with an unclosed boundary, delete the planting area and place it again.
- Different plants with the same code: If your drawing has undergone extensive edits, or if you've been using the same Land F/X project for multiple DWGs (a practice we don't recommend), you might have more than one plant variety sharing the same plant code. Check for duplicate plant codes in the Plant Manager. If you find any duplicates, give one of the plants a new code.
- Self-intersecting planting hatch boundaries: If any of your Shrub Areas or groundcover areas have self-intersecting boundaries (that is, the polyline border of the planting hatch is crossing itself), the system won't be able to make accurate calculations of the plant counts within those boundaries. If one of your groundcovers or Shrub Areas is calculating incorrectly, an area that contains that might have self-intersecting boundaries. More information & solution
- Planting hatch boundaries that intersect each other: If two (or more) planting area boundaries intersect each other, AutoCAD will be unable to calculate the plant quantities within those areas. If you see any of these intersecting polyline boundaries, move the boundaries so they don't intersect each other. Then run our Verify Labels tool. The quantities should now be correct when you place another Plant Schedule.
8. Once you've made any necessary corrections, run a Plant Schedule and select the test Work Area.
More information on running a Plant Schedule for a specific Work Area >
9. Check the quantities or areas listed in the schedule against the plants in the test Work Area. Make any necessary corrections and run additional schedules for the Work Area until you can verify that the schedule is correct.
Once you've confirmed that the plants are being calculated correctly in the test Work Area, move the Work Area to another portion of your drawing and repeat Steps 7 and 8. Repeat until you've covered your entire drawing.
10. Once you've checked your entire drawing using the test Work Area, run a Plant Schedule for the entire drawing.
Are your plants calculating correctly – and you're sure you've corrected any and all planting issues in your test Work Area?
- Yes, your plants are calculating correctly: You've resolved the issue.
- No, your plants are still not calculating correctly: The issue may be occurring in your Xrefs. Read on.
11. Check your Xrefs (if your drawing includes them).
If other DWG files have been brought into your planting plan as Xrefs, the issue may be originating from those files. For example:
- Your Plant Schedule may be including plants from your Xrefs, and you don't want it to. Or it's not including plants from your Xrefs, and you want it to.
- Your drawing and the Xref(s) containing the plants may have their units set differently. If so, the schedule will calculate the sizes of the planting areas – and thus the plant quantities themselves – incorrectly.
For example, the Xref may have its units set to Decimal Feet but your site plan (the current drawing) has its units set to Architectural Inches. In this case, the groundcover plant quantities will come in at a small fraction (1/144, to be exact) of what they should be.
- One (or more) of your Shrub Areas or groundcover areas may have a self-intersecting point, which may be preventing the Plant Schedule from calculating a correct plant count.
Our Exclude Shrubs tool can sometimes cause this issue. Exclude Shrubs automatically draws a polyline boundary around shrubs within a planting area. The spacing between the shrubs can sometimes result in interior areas and self-intersecting points in the polyline boundary.
To isolate an issue with plants from your Xrefs, verify the following items:
Is the "Include Xrefs" option (when placing your Plant Schedule) set correctly?
When generating your Plant Schedule, make sure you're selecting the appropriate option for including (or not including) plants from your Xrefs.
If you actually want to include plants from your Xrefs, check the Include Xrefs box.
If you don't want to include plants from your Xrefs, leave this box unchecked when generating your Plant Schedule.
Do your drawing units match your Xref units?
As always, your drawing should be in the same units as the attached Xrefs. Find out which units the Xrefs are in, then use our Scale tool to match those units in the current drawing. For example, if the Xref has its units set to Decimal Feet, you should also set the main drawing's units to Decimal Feet.
Have you tried our fxREF tool? fxREF provides an intuitive interface for attaching Xrefs – plus it makes it easy to check your drawing units against your Xref units.
While you're at it, make sure the scale in the main drawing matches the scale of the Xrefs. In the future, you should always be checking the scale and units of drawings before Xrefing them. You can then save yourself a great deal of trouble in the future by matching those units and scale settings in the main drawing and then bringing in your Xrefs.
12. Check whether a plant hatch (Shrub Area or groundcover) has been accidentally changed to a plant symbol (shrub or tree), but the old hatches with data weren't deleted – or vice versa.
Important: This plant symbol issue is a common one!
Many users who experience this particular issue don't realize or remember that a shrub had been placed as a hatch. The opposite could also be true, where a shrub symbol type plant was edited and changed to a hatch type (Shrub Area or groundcover), but the old block symbols with data were left in the drawing.
In these cases, the schedule will still pick up the old plants, and the quantity will appear incorrectly.
In the case of a hatch changing to a symbol, symbol spreads in the Plant Info dialog box are in feet or meters, while hatch spacing is in inches or mm. When changed to a shrub, the spread might be changed to 3', but the schedule will calculate that spread as inches for hatch spacing – 3" – which results in an extremely high quantity for any hatch (3" spacing is extremely tight!), so the issue is quite obvious as there would be hundreds or thousands too many plants in the schedule.
Also note that our Highlight Plant tool will not highlight a plant of a different symbol type (block vs. hatch). If your drawing includes old hatches, highlighting a shrub plant's block symbol will not highlight hatches with that shrub's data. In this case, you would need to edit the plant temporarily to change the category back to a hatch type in order to find the hatches with data and correct them to be a different hatch plant, or delete them.
This issue may also cause a shrub that you feel is completely deleted from the plan to keep appearing in the schedule. All the shrub symbols may have been deleted, but the old hatches from before the category edit are still in the plan and can't be highlighted. To test for and resolve this issue, see our article Plant Schedule Is Listing Plants That Aren't In Your Drawing.